Dopt - blocks.dopt.com health-check failure (automated) – Incident details

blocks.dopt.com health-check failure (automated)

Resolved
Partial outage
Started 11 months agoLasted less than a minute

Affected

APIs

Operational from 8:28 PM to 8:29 PM

blocks.dopt.com

Operational from 8:28 PM to 8:29 PM

Updates
  • Resolved
    Update

    Blocks API deploys took an abnormally long time because of a pre-existing dependency between a few internal services which were all simultaneously updated between 1:20 and 1:30 PM pacific time today.

    We've rolled out a change which decouples these services so that these 502s won't re-occur in the future.

  • Resolved
    Update

    This automated health-check failure resulted due 502s from our blocks.dopt.com gateway due to an abnormally slow roll-out of new nodes in k8s.

    We're investigating why this roll-out was so slow, but all systems are operational and functioning as expected.

  • Resolved
    Resolved

    A previously reported automated failure on health-check has been resolved.

  • Investigating
    Investigating

    We're investigating an incident which was automatically triggered by a health-check failure.